tomcat-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Mark Thomas <ma...@apache.org>
Subject Re: [GUMP@vmgump-vm3]: Project tomcat-native-1.2-1.1.1-configure (in module tomcat-native-1.2-1.1.1) failed
Date Wed, 03 Oct 2018 07:58:14 GMT
On 03/10/18 08:49, Mark Thomas wrote:
> On 03/10/18 00:54, Bill Barker wrote:
>> To whom it may engage...
>>         
>> This is an automated request, but not an unsolicited one. For 
>> more information please visit http://gump.apache.org/nagged.html, 
>> and/or contact the folk at general@gump.apache.org.
>>
>> Project tomcat-native-1.2-1.1.1-configure has an issue affecting its community integration.
> 
> <snip/>
> 
>> checking for OpenSSL library... using openssl from /srv/gump/public/workspace/openssl-1.1.1/dest-20181003/${exec_prefix}/lib
and /srv/gump/public/workspace/openssl-1.1.1/dest-20181003/include
>> checking OpenSSL library version >= 1.0.2... 
>>
>> Found   OPENSSL_VERSION_NUMBER 0x1000106f (OpenSSL 1.0.1f 6 Jan 2014)
>> Require OPENSSL_VERSION_NUMBER 0x1000200f or greater (1.0.2)
>>
>> configure: error: Your version of OpenSSL is not compatible with this version of
tcnative
> 
> This is ... odd.
> 
> The 1.1.1 branch is selected in the Gump metadata yet it reports as
> 1.0.1. Not sure what is going on here at the moment.

Problem solved. I hadn't declared the dependencies correctly. That meant
OpenSSL 1.1.1 hadn't been built by this point so it picked up 1.0.2 from
the system path.

Mark

---------------------------------------------------------------------
To unsubscribe, e-mail: dev-unsubscribe@tomcat.apache.org
For additional commands, e-mail: dev-help@tomcat.apache.org


Mime
View raw message