tomcat-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Konstantin Kolinko <knst.koli...@gmail.com>
Subject Re: Tag Tomcat 7/8.0
Date Fri, 29 Jun 2018 10:48:16 GMT
2018-06-28 23:54 GMT+03:00 Konstantin Kolinko <knst.kolinko@gmail.com>:
> 2018-06-28 23:11 GMT+03:00 Violeta Georgieva <violetagg@apache.org>:
>> Hi,
>>
>> 2018-06-26 21:16 GMT+03:00 Violeta Georgieva <violetagg@apache.org>:
>>>
>>> Hi,
>>>
>>> I'm planning to tag Tomcat 7/8.0 tomorrow.
>>> If you want to include something please reply here.
>>> Please note that this will be the last Tomcat 8.0 release.
>>
>> I'm currently not able to build Tomcat 7/8.0 when there are no dependencies.
>>
>> BUILD FAILED
>> C:\TOMCAT_7_0_89\build.xml:2761: The following error occurred while
>> executing th
>> is line:
>> C:\TOMCAT_7_0_89\build.xml:3088: Failed to download
>> [C:/temp/libs/tomcat-native-
>> 1.2.17/tomcat-native.tar.gz]. All download sources are unavailable.
>>
>>
>> Ant installation is 1.9.12.
>> I am able to download from the browser.
>>
>> Do I miss something from the latest changes in the Tomcat's build?
>
> See
> https://bz.apache.org/bugzilla/show_bug.cgi?id=62164
>
> It is not possible to download dependencies when your preferred ASF
> mirror (as auto-selected by closer.lua page) uses HTTP.
>
> This is solved by setting the property "base-apache.loc.1" in
> build.properties to the root address of your preferred mirror.
>
> In my case (see error message in comment 6 in that bug) such value is:
> base-apache.loc.1=http://apache-mirror.rbc.ru/pub/apache
>
>
> It may be that similar setting will be necessary for SourceForce, the
> property "base-sf.loc".
>
> I recently added checksum checks for downloaded files, so downloading
> over http: should be OK.

One more: the version of Java 6 that I am using is not able to
download anything over HTTPS from modern sites, due to outdated
ciphers. I have to download everything using Java 8 as a separate step
before stating a build.

For Tomcat 7.0 the command is:
ant -Dno.build.dbcp=true -Dtest.cobertura=true -Dexecute.validate=true
download-compile,download-test-compile,download-dist,download-validate,download-cobertura,extras-commons-logging-prepare,extras-webservices-prepare

For Tomcat 8.0 the command is:
ant -Dtest.cobertura=true -Dexecute.validate=true
-Dexecute.findbugs=true
download-compile,download-test-compile,download-dist,download-validate,download-cobertura,download-findbugs,extras-commons-logging-prepare,extras-webservices-prepare

For Tomcat 8.5:
ant -Dtest.cobertura=true -Dexecute.validate=true
-Dexecute.findbugs=true
download-compile,download-test-compile,download-dist,download-validate,download-cobertura,download-findbugs,extras-webservices-prepare

For Tomcat 9.0:
ant -Dtest.cobertura=true -Dexecute.validate=true
-Dexecute.findbugs=true
download-compile,download-test-compile,download-dist,download-validate,download-cobertura,download-findbugs,extras-webservices-prepare,download-bnd


Best regards,
Konstantin Kolinko

---------------------------------------------------------------------
To unsubscribe, e-mail: dev-unsubscribe@tomcat.apache.org
For additional commands, e-mail: dev-help@tomcat.apache.org


Mime
View raw message