tomcat-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Rainer Jung <>
Subject Re: OK to require tcnative 1.2.14 for TC 8.5 once it is available?
Date Sun, 03 Sep 2017 08:47:34 GMT
Am 03.09.2017 um 10:26 schrieb Mark Thomas:
> On 02/09/17 21:40, Rainer Jung wrote:
>> Backporting some fixes and enhancements from TC trunk to 8.5.x would
>> need to either require tcnative 1.2.14 or make the code more complex by
>> catching UnsatisfiedLinkError etc. and converting into error messages.
>> I don't remember very well, how we handled this in the past. Are we
>> willing to require a very fresh tcnative release in a stable branch, or
>> should we make the backport more complex and keep it version compatible,
>> or would we just postpone the backport until the tcnative version is
>> deemed to be old enough to become the required one?
>> I would prefer the first option for simplicity, but it will not be the
>> best for our users in terms of compatibility.
> We have increased the minimum version when necessary in the past. We
> last did this in 2014 when we made 1.1.32 required for 8.0.x. We did
> that shortly after the 1.1.32 release.
> I'd be happy increasing the minimum required version for 8.5.x to 1.2.14
> and the minimum recommended version to 1.2.14 for 8.0.x and 7.0.x.

That makes things much easier. The bigger backport is about 
OpenSSLConfCmd and we can limit that to 8.5. The other backport, fixing 
client cert use for Java connectors using the OpenSSL impl is 8.5 only 
in any way.

> We might want to think about announcing End of Life for 1.1.x. Given
> that 1.2.x really is a drop-in replacement for 1.1.x, I'm not sure there
> would ever be another 1.1.x release anyway.

+1 to that as well.



To unsubscribe, e-mail:
For additional commands, e-mail:

View raw message