tomcat-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From bugzi...@apache.org
Subject [Bug 59876] java.io.EOFException is thrown
Date Thu, 06 Oct 2016 08:29:45 GMT
https://bz.apache.org/bugzilla/show_bug.cgi?id=59876

--- Comment #2 from remi.lebastard@flexcom.lu ---
I have the same problem with the stack trace : 
ERROR org.atmosphere.container.JSR356Endpoint -java.io.EOFException
        at
org.apache.tomcat.util.net.NioEndpoint$NioSocketWrapper.fillReadBuffer(NioEndpoint.java:1222)
~[tomcat-coyote.jar:8.5.3]
        at
org.apache.tomcat.util.net.NioEndpoint$NioSocketWrapper.isReadyForRead(NioEndpoint.java:1128)
~[tomcat-coyote.jar:8.5.3]
        at
org.apache.tomcat.websocket.server.WsFrameServer.onDataAvailable(WsFrameServer.java:58)
~[tomcat-websocket.jar:8.5.3]
        at
org.apache.tomcat.websocket.server.WsHttpUpgradeHandler.upgradeDispatch(WsHttpUpgradeHandler.java:148)
[tomcat-websocket.jar:8.5.3]
        at
org.apache.coyote.http11.upgrade.UpgradeProcessorInternal.dispatch(UpgradeProcessorInternal.java:54)
[tomcat-coyote.jar:8.5.3]
        at
org.apache.coyote.AbstractProcessorLight.process(AbstractProcessorLight.java:53)
[tomcat-coyote.jar:8.5.3]
        at
org.apache.coyote.AbstractProtocol$ConnectionHandler.process(AbstractProtocol.java:785)
[tomcat-coyote.jar:8.5.3]
        at
org.apache.tomcat.util.net.NioEndpoint$SocketProcessor.doRun(NioEndpoint.java:1425)
[tomcat-coyote.jar:8.5.3]
        at
org.apache.tomcat.util.net.SocketProcessorBase.run(SocketProcessorBase.java:52)
[tomcat-coyote.jar:8.5.3]
        at
java.util.concurrent.ThreadPoolExecutor.runWorker(ThreadPoolExecutor.java:1142)
[?:1.8.0_91]
        at
java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:617)
[?:1.8.0_91]
        at
org.apache.tomcat.util.threads.TaskThread$WrappingRunnable.run(TaskThread.java:61)
[tomcat-util.jar:8.5.3]
        at java.lang.Thread.run(Thread.java:745) [?:1.8.0_91]

The class have changed due to tomcat development (I'm on a 8.5.3 version) but I
think it's the same bug.
The issue seems to appear only on linux environment.
I will investigate and put a test case as soon as I have a moment for that
because it's tricky to reproduce!

-- 
You are receiving this mail because:
You are the assignee for the bug.

---------------------------------------------------------------------
To unsubscribe, e-mail: dev-unsubscribe@tomcat.apache.org
For additional commands, e-mail: dev-help@tomcat.apache.org


Mime
View raw message