tomcat-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Rémy Maucherat <r...@apache.org>
Subject Re: ECJ and Java 9
Date Wed, 05 Oct 2016 14:25:44 GMT
2016-10-04 19:41 GMT+02:00 Emmanuel Bourg <ebourg@apache.org>:

> Le 4/10/2016 à 19:19, Rémy Maucherat a écrit :
>
> > Does anyone have info on Java 9 support in ECJ ? This is going to be
> needed
> > for JSP support (obviously). I tested 4.7Ms [good news: it's a drop in
> > replacement for our current 4.5] but there's no change in that area.
>
> There is a Java 9 branch in the Git repository, I don't know how much
> of the new features it supports though:
>
>   http://git.eclipse.org/c/jdt/eclipse.jdt.core.git/log/?h=BETA_JAVA9
>
> It looks like the beta builds have a tag starting with Y, this one is
> the latest available:
>
>   http://git.eclipse.org/c/jdt/eclipse.jdt.core.git/snapshot/
> Y20160929-1000.tar.gz
>
> Thanks to bothof you.

I tested this beta build, but I don't see much difference yet. It still
cannot access the base module classes it seems (errors like:
"java.lang.Throwable cannot be resolved to a type", that cannot be normal).

Also, there's an issue with the Java 9 constant that is used in Tomcat,
CompilerOptions.VERSION_1_9 -> CompilerOptions.VERSION_9. This creates a
compatibility problem where the new vs old build cannot be drop in
replacements.

Rémy

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message