tomcat-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Matt Cosentino <mcosent...@cacorp.com>
Subject RE: Tomcat 8.5: Avoid NPE on bind for APR when using SSL.
Date Wed, 22 Jun 2016 18:19:24 GMT
I figured out the problem. The NPE was occurring because it couldn’t match the default SSLHostConfig.
The documentation says to use the sslDefaultHost attribute of the Connector, but I get warnings
saying that no matching property is found. I had to dig into the code to find that the correct
attribute is defaultSSLHostConfigName. The documentation should be updated to reflect this.

https://tomcat.apache.org/migration-85.html

- Matt


-----Original Message-----
From: Matt Cosentino 
Sent: Friday, May 27, 2016 2:15 PM
To: 'Tomcat Developers List' <dev@tomcat.apache.org>
Subject: RE: Tomcat 8.5: Avoid NPE on bind for APR when using SSL.

I see, that explains why it isn't in 8.5, thanks for the helpful response. I'll investigate
further why the NPE is still occurring.

- Matt


-----Original Message-----
From: Coty Sutherland [mailto:csutherl@redhat.com] 
Sent: Friday, May 27, 2016 1:27 PM
To: Tomcat Developers List <dev@tomcat.apache.org>
Subject: Re: Tomcat 8.5: Avoid NPE on bind for APR when using SSL.

> It may have been branched in March, but wouldn't it have been branched from the 8.0 base?
This change from 9.0 is not in the 8.5 code and the NPE still occurs.

No, 8.5 was branched from trunk and therefore included the revision that you pointed out.
Please see the dev list thread titled "Tomcat 8.next" for more information on the 8.5 origin.
Additionally, looking at the mergeinfo in svn (svn mergeinfo ^/tomcat/trunk@1726515) shows
that it was forked from trunk. If you looked at the 8.5 AprEndpoint class and don't see the
change, it's because it was changed by
r1727667 on 1/29 (r1726515 was included on 1/24).

On Fri, May 27, 2016 at 12:24 PM, Matt Cosentino <mcosentino@cacorp.com> wrote:
> It may have been branched in March, but wouldn't it have been branched from the 8.0 base?
This change from 9.0 is not in the 8.5 code and the NPE still occurs.
>
> Bringing an issue to your attention is spamming?
>
> - Matt
>
>
> -----Original Message-----
> From: Rémy Maucherat [mailto:remm@apache.org]
> Sent: Friday, May 27, 2016 11:06 AM
> To: Tomcat Developers List <dev@tomcat.apache.org>
> Subject: Re: Tomcat 8.5: Avoid NPE on bind for APR when using SSL.
>
> 2016-05-27 17:45 GMT+02:00 Matt Cosentino <mcosentino@cacorp.com>:
>
>> No? 8.5 suffers from the same NPE.
>>
>> First, 8.5 was branched in March, then I am not happy about being spammed.
>
> Rémy

---------------------------------------------------------------------
To unsubscribe, e-mail: dev-unsubscribe@tomcat.apache.org For additional commands, e-mail:
dev-help@tomcat.apache.org

Mime
View raw message