tomcat-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From therealnewo...@gmail.com
Subject Re: Bug that spans tomcat and tomcat-native
Date Fri, 24 Jun 2016 14:40:58 GMT
On Fri, Jun 24, 2016 at 6:17 AM, Rémy Maucherat <remm@apache.org> wrote:
> 2016-06-24 12:08 GMT+02:00 Mark Thomas <markt@apache.org>:
>
>> Thanks.
>>
>> I'm going to start some local performance testing to confirm I see
>> similar results and, assuming I do, I'll start looking at fixing this
>> for 1.2.x/9.0.x and back-porting.
>>
>> Hum, the fix that was submitted doesn't make sense IMO since writes can be
> async, so I don't see a way besides adding the "error clear" thing after
> each operation [and we'll remove it once OpenSSL 1.1 is there if it
> actually fixes it]. That's assuming this issue is real [I actually never
> noticed anything during my many ab runs and they use a lot of threads, so I
> have a hard time believing it is significant enough ;) ].
>

One thing about the system on which this is running is that it has a
10G nic. So the slow case is about 350MB/s and the fast one is 700MB/s
so you would need a 10G interface or use loop back to even notice the
issue assuming the CPU on the system can push that much encrypted
data.

-nate

---------------------------------------------------------------------
To unsubscribe, e-mail: dev-unsubscribe@tomcat.apache.org
For additional commands, e-mail: dev-help@tomcat.apache.org


Mime
View raw message