tomcat-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Mark Thomas <ma...@apache.org>
Subject Re: Bug that spans tomcat and tomcat-native
Date Fri, 24 Jun 2016 15:18:57 GMT
On 24/06/2016 11:17, Rémy Maucherat wrote:
> 2016-06-24 12:08 GMT+02:00 Mark Thomas <markt@apache.org>:
> 
>> Thanks.
>>
>> I'm going to start some local performance testing to confirm I see
>> similar results and, assuming I do, I'll start looking at fixing this
>> for 1.2.x/9.0.x and back-porting.
>>
> Hum, the fix that was submitted doesn't make sense IMO since writes can be
> async, so I don't see a way besides adding the "error clear" thing after
> each operation [and we'll remove it once OpenSSL 1.1 is there if it
> actually fixes it]. That's assuming this issue is real [I actually never
> noticed anything during my many ab runs and they use a lot of threads, so I
> have a hard time believing it is significant enough ;) ].

I haven't been able to reproduce anything like this yet. So far I have
only been testing with tc-native 1.2.x and Tomcat 9.0.x. I might need to
test with 1.1.x and Tomcat 7.0.x, the versions used by the OP.

I'm having trouble understanding how this is happening. I could imagine
that HashMap becoming a problem if there was a high churn in Threads.
I'm thinking of something like bursty traffic levels and an executor
aggressively halting spare threads. I need to experiment with that as well.

Nate,

We need as much information as you can provide on how to reproduce this.
As a minimum we need to know:
- Connector configuration from server.xml
- Operating system
- How tc-native was built
- Exact versions for everything

We need enough information to recreate the test and the results
that you obtained.

Mark


---------------------------------------------------------------------
To unsubscribe, e-mail: dev-unsubscribe@tomcat.apache.org
For additional commands, e-mail: dev-help@tomcat.apache.org


Mime
View raw message