tomcat-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From bugzi...@apache.org
Subject [Bug 56283] Add support for Java 8 to Jasper
Date Fri, 04 Apr 2014 18:29:03 GMT
https://issues.apache.org/bugzilla/show_bug.cgi?id=56283

--- Comment #2 from Konstantin Kolinko <knst.kolinko@gmail.com> ---
Note 1.

Technically CompilerOptions.VERSION_1_8 is a String constant "1.8", so it will
be inlined at compile time.

At runtime Tomcat/Jasper will be compatible with any other version of ECJ
4.3.x, e.g. 4.3.1.

Note 2.

All 547 classes in ecj-P20140317-1600.jar have format version 50.0 (Java 1.6).
As such, this jar cannot be used to build Tomcat 6.

For historical record, I applied the change to Tomcat 6 in r1584800 but had to
revert it right away in r1584806.

-- 
You are receiving this mail because:
You are the assignee for the bug.

---------------------------------------------------------------------
To unsubscribe, e-mail: dev-unsubscribe@tomcat.apache.org
For additional commands, e-mail: dev-help@tomcat.apache.org


Mime
View raw message