tomcat-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Christopher Schultz <ch...@christopherschultz.net>
Subject Re: udp port used by the tribes tests
Date Wed, 30 Apr 2014 19:49:30 GMT
Jean-Frederic,

On 4/30/14, 9:21 AM, jean-frederic clere wrote:
> On 04/30/2014 12:57 AM, Konstantin Kolinko wrote:
>> 2014-04-29 18:57 GMT+04:00 Konstantin Kolinko <knst.kolinko@gmail.com>:
>>> 2014-04-29 18:41 GMT+04:00 jean-frederic clere <jfclere@gmail.com>:
>>>> Hi,
>>>>
>>>> Does someone know which upd ports are used by the tribes tests?
>>>> I tried to allow 4000-4005 but that didn't help :-(
>>>>
>>>
>>>  From old e-mails in my mailbox I think so. (Some test error messages
>>> mention port numbers). I have not looked into the code.
>>>
>>> Maybe try running org.apache.catalina.tribes.TesterMulticast ?
>>> It is mentioned in BUILDING.txt
>>
>> Looking at souŠ³ce code and searching through log files of a full
>> Tomcat8 tests run with NIO connector, I can say the following.
>>
>>
>> 4000-4005 are TCP ports
>>
>> The only test that has UDP enabled is
>> org.apache.catalina.tribes.group.TestGroupChannelStartStop
>> It uses "udpPort = 45543".
> 
> I was testing tomcat7 I have open 4000-4005 TCP and 45543 UDP that
> didn't help, I will test Tomcat8 later.
> 
> Of course removing the firewall helps ;-)

How about setting iptables to "-j LOG" for all, and then checking for a
flurry of data when you run the test(s)?

-chris


Mime
View raw message