tomcat-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Henri Gomez <>
Subject Re: tomcat-native and OS/X
Date Wed, 13 Jul 2011 15:28:44 GMT
I added both arch in build and it seems to works :

CFLAGS='-arch i386 -arch x86_64' APXSLDFLAGS='-arch i386 -arch x86_64'
./configure --with-apr=/usr --with-ssl=/usr

You may also add PowerPC support like this :

CFLAGS='-arch ppc -arch i386 -arch ppc64 -arch x86_64'
APXSLDFLAGS='-arch ppc -arch i386 -arch ppc64 -arch x86_64'
./configure --with-apr=/usr --with-ssl=/usr

Thanks again Mladen, you pointed the problem

2011/7/13 Henri Gomez <>:
>>> I tried to rebuild and install under latest OS/X 10.6.8 but Tomcat 6
>>> still didn't detect it.
>> Have you tried starting tomcat with 'java -d32/-d64'
>> Might be the wrong ABI (32/64-bit) gets used.
> You got it Mladen :)
> I was using -d32 and in such case it didn't works
> back to normal with -d64.
> I should figure how to build a 32bits version.
> 32/64 bits mixed models on OS/X are sometime complex :)

To unsubscribe, e-mail:
For additional commands, e-mail:

View raw message