tomcat-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Tim Funk <>
Subject Re: [5] Unable to initialize TldLocationsCache: zip file closed
Date Wed, 08 Oct 2003 12:15:16 GMT
No luck. I have had trouble in the past with HP JVMs and this is an old JVM.

No errors are output when the webapp is loaded. Just when the first JSP tries 
to get compiled.

As a sanity check, I removed the precompile mappings for the JSP examples and 
most examples worked fine. But then one of the pages got an error 
(jsp-examples/xml/xml.jsp), then nothing worked for jsp-examples. I deleted 
work/Catalina/localhost/jsp-examples/ and had multiple tomcat restarts with 
no luck.

My first todo will be to get a newer JVM (1.3 or 1.4) for that machine and 
see how things go. I am not going to pull my hair out on this one until I can 
reproduce this with a newer JVM for that box. (Something I'll not be allowed 
to do soon for that machine :( )


Remy Maucherat wrote:
> Tim Funk wrote:
>> Quick summary:
>> In, line 129 is
>> DocumentBuilderFactory factory = DocumentBuilderFactory.newInstance();
>> Does anyone know how DocumentBuilderFactory.newInstance() can throw 
>> "java.lang.IllegalStateException: zip file closed"?
> This happens when attempting to open a JAR from common/lib (or 
> common/endorsed). This code hasn't changed for a long while.
> However, this CL (since it loads stuff which doesn't need to be updated) 
> opens the URL without setting caches to false (BTW, whay isn't there a 
> $%%$#%#%$#%$ global setting for this ???).
> I never got this error before. Maybe we should set the caches to false 
> in StdCL.getResourceAsStream ? Does that fix it in your case ?

To unsubscribe, e-mail:
For additional commands, e-mail:

View raw message