tomcat-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Glenn Nielsen <gl...@mail.more.net>
Subject Re: mod_jk 1.2.3 source release ready for binary build/testing
Date Wed, 14 May 2003 20:10:26 GMT
Please provide more information from your Apache httpd.conf and
your Tomcat server.xml so I can look into this further.  Things
of interest are your Apache DocumentRoot, Host webapp DocBase,
Context configs, etc.

Thanks,

Glenn


Jess M. Holle wrote:
> Glenn Nielsen wrote:
> 
>> The Windows/Unix incompatability problem for the Apache 2 version of 
>> mod_jk 1.2.3 should
>> now be resolved.  I have also modified the hook priorities and tested 
>> them for Apache 2.0.
>> Both mod_alias and mod_dir are working the way they should.
>>
>> Please build binaries for different platforms and test.
>>
>> When a number of OS's/platforms have been built and tested 
>> successfully I will
>> announce this release. 
> 
> 
>> New source distribution available at:
>>
>> http://jakarta.apache.org/builds/jakarta-tomcat-connectors/jk/release/v1.2.3/src/

>>
> 
> 
> I built this on Windows against both Apache 1.3.27 and 2.0.45.
> 
> It worked fine against 1.3.27 in my minimalistic testing.
> 
> It did NOT seem to work at all in 2.0.45.  Specifically, it loaded, 
> created an empty log file (despite the fact that I specified JkLogLevel 
> debug) and nothing more.  The JkMount directive that worked fine with 
> the same Apache with mod_jk 1.2.2 (built in the same fashion against the 
> same Apache) resulted in me getting JSP source.
> 
> I noticed the 2.0.45 binary for Windows on the site -- and it gave me 
> the same problem.
> 
> Anyone else see this problem?  My relevant conf directives are:
> 
>    LoadModule jk_module modules/mod_jk.dll
> 
>    <IfModule mod_jk.c>
>       JkWorkersFile conf/workers.properties
>       JkLogFile logs/mod_jk.log
>       JkLogLevel error
>       JkMount /*.jsp ajp13
>       JkMount /*.jsp/* ajp13
>    </IfModule>
> 
> and my relevant workers.properties entries are:
> 
>    worker.ajp13.port=8009
>    worker.ajp13.host=localhost
>    worker.ajp13.type=ajp13
>    worker.ajp13.lbfactor=1
>    worker.loadbalancer.type=lb
>    worker.loadbalancer.balanced_workers=ajp13
> 
>    [I can attach the whole thing if it turns out to be relevant...]
> 
> Note that these settings were essentially the same in the Apache 1.3.27 
> test.
> 
> [I was anxious to move to this release due to the issues supposedly 
> fixed, but this is currently a non-starter as I need a single version 
> for Apache 1.3.27 (on UNIX actually) and 2.0.45 on Windows.]
> 
> -- 
> Jess Holle
> 
> 


-- 
----------------------------------------------------------------------
Glenn Nielsen             glenn@more.net | /* Spelin donut madder    |
MOREnet System Programming               |  * if iz ina coment.      |
Missouri Research and Education Network  |  */                       |
----------------------------------------------------------------------


---------------------------------------------------------------------
To unsubscribe, e-mail: tomcat-dev-unsubscribe@jakarta.apache.org
For additional commands, e-mail: tomcat-dev-help@jakarta.apache.org


Mime
View raw message