tomcat-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Simon Stewart <...@lateral.net>
Subject Re: Configuring mod_jk2
Date Tue, 25 Jun 2002 14:55:44 GMT
On Tue, Jun 25, 2002 at 01:13:02PM +0200, Mladen Turk wrote:
> > -----Original Message-----
> > From: Simon Stewart [mailto:sms@lateral.net] 
> > Sent: 25. lipanj 2002 12:57
> > To: tomcat-dev@jakarta.apache.org
> > Subject: RE: Configuring mod_jk2
> > 
> > 
> > Mladen also mentioned the "RegisterNatives" directive 
> > "inprocess". I'm about to go searching through the archives 
> > of the list, but if someone would please take the time to 
> > explain it to me what it is, I'd be grateful. Anyone?
> >
>  
> This one goes to the jk2.properties, not the workers2.properties, sorry.
> 
> The RegisterNatives is the JNI way that we are using to force the
> mod_jk2 to register its native methods instead of using that from Java,
> so that we don't need to explicitly use the System.loadLibrary.
> 
> The option can be enabled with the directive:
> apr.jniModeSo=inprocess 
> In the jk2.properties.
> 
> The AprImpl in that case will skip the loading of the jni library, and
> mod_jk2 will register all the natives.

Does this mean that I can skip the apr.NativeSo directive in this
file? What is the expected output when this line is included? When I
omit the explicit loading of the libjkjni.so file, I get:

25-Jun-2002 15:44:46 org.apache.jk.server.JkMain init
INFO: Starting Jk2, base dir= /home/sms/tomcat conf=/home/sms/tomcat/conf/jk2.properties
25-Jun-2002 15:44:46 org.apache.jk.server.JkMain start
INFO: APR not loaded, disabling jni components: java.io.IOException: no jkjni in java.library.path
25-Jun-2002 15:44:46 org.apache.jk.common.ChannelSocket init
INFO: JK: listening on tcp port 8009
25-Jun-2002 15:44:46 org.apache.jk.server.JkMain start
INFO: Jk running ID=0 ... init time=383 ms
Starting service Tomcat-Standalone
Apache Tomcat/4.0.4

And connections using a UNIX domain socket fail. With the line
included everything appears to work, but how can I tell if
RegisterNatives is working?

Regards,

Simon

-- 
"Shouldn't you read the instructions?"   -Hobbes
"Do I look like a sissy?"                -Calvin

--
To unsubscribe, e-mail:   <mailto:tomcat-dev-unsubscribe@jakarta.apache.org>
For additional commands, e-mail: <mailto:tomcat-dev-help@jakarta.apache.org>


Mime
View raw message