tomcat-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Kevin Jones" <kev...@develop.com>
Subject RE: Form based logon problems in T4B6
Date Wed, 25 Jul 2001 21:06:07 GMT
OK

Kevin Jones
DevelopMentor
www.develop.com

> -----Original Message-----
> From: Craig R. McClanahan [mailto:craigmcc@apache.org]
> Sent: 25 July 2001 00:10
> To: Tomcat-Dev
> Subject: Re: Form based logon problems in T4B6
>
>
> Sounds like a bug introduced when the functionality was modified recently,
> to do redirects instead of forwards.  Could you do me a favor and file a
> bug report so it gets tracked?
>
> Thanks,
> Craig
>
>
> On Tue, 24 Jul 2001, Kevin Jones wrote:
>
> > I can't get form based logon to work reliably in Beta6 (in fact I've had
> > problems for a while)
> >
> > I have a webapp (called course) and a sub directory (gjava) which is
> > protected. I'm using form based logon with the username and password in
> > tomcat-users.xml.
> >
> > i) If I try and access a resource in \course\gjava I get the
> logon page, if
> > I enter a valid username and password everything works.
> >
> > ii) If I try and access a resource in \course\gjava I get the
> logon page, if
> > I enter an invalid username and password I get the logon page
> again - *not*
> > the error page.
> >
> > iii) If I try and access a resource in \course\gjava I get the
> logon page,
> > if I enter a valid username and password everything works. But
> if I hit the
> > back button and then enter an invalid username/password I get redirected
> > here http://localhost/course/gjava/j_security_check and get a 404 error
> >
> > iv) If I try and access a resource in \course\gjava I get the
> logon page, if
> > I enter an invalid username and password I get the logon page
> again - *not*
> > the error page. If I now enter the correct password I get the
> error page,
> >
> > Kevin Jones
> > DevelopMentor
> > www.develop.com
> >
> >
>


Mime
View raw message