tomcat-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Jason Harrop <>
Subject [TC4] SingleSignOnSupport broken?
Date Thu, 01 Mar 2001 13:55:34 GMT

I'm using the TC4 sources from cvs from Feb 17 (well after the last 
commit to org.apache.catalina.authenticator.SingleSignOn), with SlideRealm.

I had been using three different webapps; each web.xml file had 
identical realm name, as in:


Without the SingleSignOn valve, this worked well; well, subject to a 
problem with Internet Explorer which i'm asking about in a separate post.

Because of that problem with Internet Explorer, i tried single sign on 
support instead.  However, it doesn't appear to work, in that I get an 
authentication challenge for each new realm (when i give the realm in 
each webapp a different name), and the logs always say "Checking for SSO 
cookie - SSO cookie is not present", as in:

2001-03-02 00:28:50 StandardHost[localhost]: Mapping request URI 
2001-03-02 00:28:50 StandardHost[localhost]:   Trying the longest 
context path prefix
2001-03-02 00:28:50 StandardHost[localhost]:  Mapped to context 
2001-03-02 00:28:56 SingleSignOn[localhost]: Process request for 
2001-03-02 00:28:56 SingleSignOn[localhost]:  Checking for SSO cookie
2001-03-02 00:28:56 SingleSignOn[localhost]:  SSO cookie is not present

i have turned on user cookie approval in the browser, and the only 
cookie which is getting set is the JSESSIONID cookie.

Am i doing something which is obviously wrong? I've got the valve at the 
Host level.



View raw message