tomcat-announce mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Mark Thomas <ma...@apache.org>
Subject [SECURITY] CVE-2019-0199 Apache Tomcat HTTP/2 DoS
Date Mon, 25 Mar 2019 09:26:53 GMT
CVE-2019-0199 Apache Tomcat HTTP/2 DoS

Severity: Important

Vendor: The Apache Software Foundation

Versions Affected:
Apache Tomcat 9.0.0.M1 to 9.0.14
Apache Tomcat 8.5.0 to 8.5.37

Description:
The HTTP/2 implementation accepted streams with excessive numbers of
SETTINGS frames and also permitted clients to keep streams open without
reading/writing request/response data. By keeping streams open for
requests that utilised the Servlet API's blocking I/O, clients were able
to cause server-side threads to block eventually leading to thread
exhaustion and a DoS.

Mitigation:
Users of affected versions should apply one of the following mitigations:
- Upgrade to Apache Tomcat 9.0.16 or later
  Note: Apache Tomcat 9.0.15 contains the necessary fixes but was not
        released
- Upgrade to Apache Tomcat 8.5.38 or later

Credit:
The issue with excessive SETTINGS frames was reported by Michal Karm
Babacek from Red Hat, Inc. As a result of his report the Tomcat Security
team identified additional issues related to read/write timeouts.


References:
[1] http://tomcat.apache.org/security-9.html
[2] http://tomcat.apache.org/security-8.html

Mime
View raw message