tez-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Saikat (JIRA)" <j...@apache.org>
Subject [jira] [Comment Edited] (TEZ-2613) Fetcher(unordered) using List to store InputAttemptIdentifier can lead to some inefficiency during remove() operation
Date Tue, 14 Jul 2015 21:49:04 GMT

    [ https://issues.apache.org/jira/browse/TEZ-2613?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=14627099#comment-14627099
] 

Saikat edited comment on TEZ-2613 at 7/14/15 9:48 PM:
------------------------------------------------------

changes:
1. keep one remaining list instead of two srcAttempts and remaining list.(doubt:why do we
need 2 list?)
2. Make a subclass InputAttemptIndentiferWithSpills which overrides the hashcode and equals
method.
3. Make a custom wrapper InputAttemptIndentiferList class to encapsulate differnt types of
InputAttemptIdentifier objects
4. Test cases for the InputAttemptIndentiferList


If this patch is accepted, similar changes can be made to Ordered Fetchers.


was (Author: saikatr):
changes:
1. keep one remaining list instead of two srcAttempts and remaining list.(doubt:why do we
need 2 list?)
2. Make a subclass InputAttemptIndentiferWithSpills which overrides the hashcode and equals
method.
3. Make a custom wrapper InputAttemptIndentiferList class to encapsulate differnt types of
InputAttemptIdentifier objects
4. Test cases for the InputAttemptIndentiferList

> Fetcher(unordered) using List to store InputAttemptIdentifier can lead to some inefficiency
during remove() operation
> ---------------------------------------------------------------------------------------------------------------------
>
>                 Key: TEZ-2613
>                 URL: https://issues.apache.org/jira/browse/TEZ-2613
>             Project: Apache Tez
>          Issue Type: Improvement
>            Reporter: Saikat
>            Assignee: Saikat
>         Attachments: TEZ-2613.patch
>
>
> remove() operation on the remaining list can be inefficient. 



--
This message was sent by Atlassian JIRA
(v6.3.4#6332)

Mime
View raw message