subversion-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Branko Čibej <br...@apache.org>
Subject Re: FW: Error with svn
Date Sun, 23 Dec 2018 10:27:41 GMT
On 20.12.2018 17:59, Branko Čibej wrote:
> On 20.12.2018 13:41, Руслан Самигуллин wrote:
>> I have running Subversion on 64-bit Win and on 32-bit Win. Maybe I am wrong for this
command, I found it on this web site: https://stackoverflow.com/questions/11300633/svn-cannot-set-lc-ctype-locale
>
> This answer on StackOverflow is only for Debian Linux and related
> (Ubuntu, Mint, etc.). It won't work on Windows.
>
>
>> I said that I don`t know how to fix my problem on Win. Please help me. What command
is needed to set “variable LANG” or another way to solve this problem?
> For some reason your regional setting on Windows are not correct.
> Subversion uses 'setlocale(LC_ALL, "")' and if that fails,
> 'setlocale(LC_CTYPE, "")'. This should always work on Windows; I don't
> know why it doesn't.
>
> See:
> https://docs.microsoft.com/en-us/cpp/c-runtime-library/reference/setlocale-wsetlocale
>
> Are you sure you're using a native Windows binary of Subversion, not
> something built for Cygwin or WSL?
>
>
> -- Brane
>
>
>> From: Branko Čibej
>> Sent: Thursday, 20 December 2018 15:17
>> To: Руслан Самигуллин; users@subversion.apache.org
>> Subject: Re: Error with svn
>>
>> On 20.12.2018 11:31, Руслан Самигуллин wrote:
>>> Hello!
>>>
>>> I have a problem with svn. The problem appears when I run svn.exe. I have Windows
10 x64, and this problem appears in Win10 x32.
>>>
>>> The text from the console window is reduced below:
>>>
>>> svn: warning: cannot set LC_CTYPE locale
>>> svn: warning: environment variable LANG is not set
>>> svn: warning: please check that your locale name is correct
>>>
>>> I found that have to install language pack like that: (sudo apt-get install language-pack-en-base)
and set it like that: (export LC_ALL=C) but I don`t know how to do it. And in what catalogue
I must write the command to install in cmd?
>> I'm confused: You say you're running 32-bit Subversion binaries on
>> 64-bit Windows, but then you show the proposed 'fix' as commands that
>> would work on some Debian-based Linux distribution? That can't be right.
>> Where did you get those commands from?
>>


Руслан, please respond here instead of starting a new thread with the
same topic.

-- Brane


Mime
View raw message