subversion-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Kris Deugau <kdeu...@vianet.ca>
Subject Re: subversion 1.11.0 on FreeBSD 11.2: ... does not support the HTTP/DAV protocol
Date Mon, 05 Nov 2018 22:48:45 GMT
Dr. Rolf Jansen wrote:
> The default version of Subversion in the Ports of FreeBSD has been switched from 1.10.3
to 1.11.0 in the last week. After running the monthly update of my FreeBSD machines I cannot
connect to HTTPS repositories anymore.
> 
> I submitted a bug report to FreeBSD, see: https://bugs.freebsd.org/bugzilla/show_bug.cgi?id=232945
> 
> The FreeBSD subversion port maintainer, verified that the same issue happens with subversion
1.11 on Linux and Windows as well, and he asked me to report the issue here.
> 
> In the meantime I deinstalled all subversion packages built from the FreeBSD ports system,
and I built and installed subversion 1.11.0 from the upstream sources (thats’s yours) -
see below. Needless to say that 1.10.3 does not show the issue below, and of course the GitHub
server does support HTTP/DAV.

If you check the list archives, you'll see that the thread immediately 
before yours, "Problems accessing GitHub's SVN-bridge with SVN 1.11", is 
about the exact same issue.

Unless I've completely misunderstood that thread, GitHub's custom 
re-implmentation of SVN's HTTP/DAV support is slightly buggy, in that it 
does not actually properly implement the underlying HTTP DAV protocol. 
It's only now become an issue due to Subversion getting stricter about 
checking for DAV protocol elements to better report certain errors.

-kgd

Mime
View raw message