subversion-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Johannes van der Vegt" <Johannes.van.der.V...@applicos.com>
Subject SVN access became slow
Date Tue, 05 Jun 2018 08:16:15 GMT
Hi group,

 

Suddenly SVN access became very slow on my PC. Before, everything ran fine.

 

We have a small company network.

*	"Server" PC: Win10 Pro (1709), runs the svnserve.exe service,
version 1.10.0
*	My PC: Win10Pro (1803), using SVN 1.10.0-dev (Apr 14, 2018)
*	Other PC: Win10Pro (1803)

 

When I run "svn info svn://server/RepoPath", I need to wait very long (over
40 seconds) before I get the response.

When I use the server's specific IPv4 address, it responds immediately.

When I use the server's specific IPv6 address, I get errors:

svn: E170013: Unable to connect to a repository at URL
'svn://[fe80::c0a0:7afa:1cxx:xx9d]/RepoPath'

svn: E730060: Can't connect to host 'fe80::c0a0:7afa:1cxx:xx9d': A
connection attempt failed because the connected party did not properly
respond after a period of time, or established connection failed because
connected host has failed to respond.

When I run "svn info svn://server/RepoPath" from another PC on our network,
it runs fine.

 

I thought there might be a NetBIOS name resolution issue. But running a
normal "ping server" immediately stars pinging via IPv6, so I figure NetBIOS
works fine here.

I have sniffed around with WireShark. I am really a novice here, so having
misinterpreted my observations Is very well possible. But I noticed that the
initial request (using the NetBIOS name) to the server goes via IPv6
addresses, but the data is returned via IPv4 addresses. This is on my PC,
and also on the other PC in our network. Would this be normal?

 

I already disabled the Windows firewall on both server and client, but to no
avail.

 

I'm not sure what to do next. Any clues?

 

I'm not subscribed to this mailing list, so being explicitly CC:ed in any
response would be appreciated.

 

Thanks,

Johannes

 

 


Mime
View raw message