subversion-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Johan Corveleyn <>
Subject Re: Cannot add files due to hierarchical RDC svn:auto-props when matching rules merge properties between text and binary file types
Date Sat, 15 Oct 2016 20:59:28 GMT
On Sat, Oct 15, 2016 at 10:10 PM, Johan Corveleyn <> wrote:
> On Fri, Oct 14, 2016 at 4:21 PM, Branko ─îibej <> wrote:
>> On 14.10.2016 09:17, Johan Corveleyn wrote:
>>> FWIW, I think you have a valid usecase, though it's a bit unusual. Of
>>> your proposed solutions, I think 1 and 2 are not possible (1 breaks
>>> backwards compatibility
>> On the other hand, I'd argue that the behaviour as described is a bug
>> and that 1 is actually correct: an identical rule (identical glob
>> pattern) in svn:auto-props property should completely override the rule
>> from an inherited svn:auto-props property. Anything else leads to
>> madness, as this thread shows.
> Hm, yes, maybe you're right. In case of identical glob pattern in
> svn:auto-props perhaps, yes.
> Rereading the relevant section of the release notes [1], perhaps it
> was even explicitly designed to behave that way, but maybe there is a
> bug in the implementation. The release notes say:
> [[[
> Patterns defined in svn:auto-props property override any identical
> patterns in the auto-props runtime config. When multiple
> svn:auto-props properties apply to a file, the pattern from the
> nearest inheritable property takes precedence. See this section of
> design wiki for a full explanation.
> ]]]
> FTR: I haven't yet tried to reproduce the problem Rob was seeing.
> Maybe I'll try later.
> [1]

Well, it reproduces allright, both with 1.9.4 and with a trunk client:

C:\autoprops>svn --version -q

C:\autoprops>svnadmin create repos

C:\autoprops>svn mkdir -mm --parents file:///c:/autoprops/repos/trunk/dir
Committing transaction...
Committed revision 1.

C:\autoprops>svn co file:///c:/autoprops/repos/ wc
A    wc\trunk
A    wc\trunk\dir
Checked out revision 1.

C:\autoprops>cd wc

C:\autoprops\wc>svn ps svn:auto-props "*.txt = svn:eol-style=native" .
property 'svn:auto-props' set on '.'

C:\autoprops\wc>svn ps svn:auto-props "*.txt =
svn:mime-type=application/octet-stream" trunk
property 'svn:auto-props' set on 'trunk'

C:\autoprops\wc>svn st
 M      .
 M      trunk

C:\autoprops\wc>svn ci -mm
Sending        .
Sending        trunk
Committing transaction...
Committed revision 2.

C:\autoprops\wc>svn up
Updating '.':
At revision 2.

C:\autoprops\wc>cd trunk/dir

C:\autoprops\wc\trunk\dir>svn pg svn:auto-props --show-inherited-props
C:\autoprops\wc - *.txt = svn:eol-style=native

C:\autoprops\wc\trunk - *.txt = svn:mime-type=application/octet-stream

C:\autoprops\wc\trunk\dir>echo test>test.txt

C:\autoprops\wc\trunk\dir>svn add test.txt
svn: E200009: Can't set 'svn:eol-style': file
'C:\autoprops\wc\trunk\dir\test.txt' has binary mime type property

(same error when I execute the last command with a trunk client)


View raw message