subversion-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Trent Fisher <trent.fis...@oracle.com>
Subject Bug with svnadmin dump --deltas??
Date Wed, 08 Jun 2016 01:05:10 GMT
I think I found a bug with svnadmin dump --deltas.  It all started with 
an svnsync replication which got "svnsync: E210008: Error while 
replaying commit".  I tried doing an svnrdump dump of the failing 
revision from the remote repository, and tried to load that and got this 
error.

svnadmin: E200014: Base checksum mismatch on 
'/blah/blah/blah/META-INF/MANIFEST.MF':
    expected:  91130ebbf7425816cc82ad08be4bb128
      actual:  80d4dede1743346affe4fe5e52cd280e

But then I tried doing an svnadmin dump via ssh, and that loaded 
cleanly.  Looking at the dump file from each, I noticed that the 
svnrdump had deltas and that the expected checksum, shown above, matched 
the 'Text-delta-base-md5' line in the dump file not the 
'Text-content-md5' line.  So then I tried doing an svnadmin dump 
--deltas, and it produced the exact same dump output as svnrdump. This 
makes me think that something about the --deltas output, or the 
interpretation of it at load time, is incorrect.  I'm not sure how to 
track it down to a reproducible case, any suggestions would be welcome.

My servers are both Linux OEL (Oracle's RHEL variant), both with 
Subversion 1.8.15.

++thanks,
trent...



Mime
View raw message