subversion-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Somashekarappa, Anup (CWM-NR)" <anup.somashekara...@rbc.com>
Subject RE: SVN upgrade
Date Thu, 16 Jun 2016 11:05:26 GMT

Hello,

Is the pkgconfig related to apr or apr-util or it is independent of it?

[USER@server subversion-1.9.4]$ make install
/usr/bin/install -c -d /usr/local/lib /usr/local/share/pkgconfig
/usr/bin/install: cannot change permissions of `/usr/local/share/pkgconfig': No such file
or directory
make: *** [install-fsmod-lib] Error 1


From: Stefan Hett [mailto:stefan@egosoft.com]
Sent: 2016, June, 15 8:32 AM
To: users@subversion.apache.org
Subject: Re: SVN upgrade

Hi,

Hello,

Thank you for your quick response.

I am able to proceed further but stuck at

[USER@server subversion-1.9.4]$ make install
/usr/bin/install -c -d /usr/local/lib /usr/local/share/pkgconfig
/usr/bin/install: cannot change permissions of `/usr/local/share/pkgconfig': No such file
or directory
make: *** [install-fsmod-lib] Error 1
I take it you already troubleshooted the issue yourself and ruled out the obvious candidates
like missing pkgconfig, missing permissions, and everything else google would point out in
the first few links when searching the web for that error message, right?
If so, knowing your linux distribution would be useful.




From: Stefan Hett [mailto:stefan@egosoft.com]
Sent: 2016, June, 15 8:04 AM
To: users@subversion.apache.org<mailto:users@subversion.apache.org>
Subject: Re: SVN upgrade

On 6/15/2016 1:50 PM, Somashekarappa, Anup (CWM-NR) wrote:

Hi,

I am trying t compile the source code to upgrade from SVN 1.7 to 1.9.4 but I am getting the
below error.

Could you please send the steps for upgrading since I couldn’t find any good document in
web ?

I am trying to follow the steps mentioned in http://svn.apache.org/repos/asf/subversion/trunk/INSTALL
.

And I want to upgrade in Linux

[USER@server subversion-1.9.4]$ sh autogen.sh
: command not found:
: command not found:
: command not found:
': not a valid identifiert: `CDPATH
: command not found:
'utogen.sh: line 35: syntax error near unexpected token `in
'utogen.sh: line 35: `  case "$1" in
Given the output you have here, I take it you downloaded the source as a tarball instead of
getting it directly form the repository. In this case, please follow the instructions in INSTALL
under II.A instead II.B.
I.e. run
./configure
make
make install




--

Regards,

Stefan Hett

_______________________________________________________________________

This email is intended only for the use of the individual(s) to whom it is addressed and may
be privileged and confidential.
Unauthorised use or disclosure is prohibited. If you receive This e-mail in error, please
advise immediately and delete the original message.
This message may have been altered without your or our knowledge and the sender does not accept
any liability for any errors or omissions in the message.

Ce courriel est confidentiel et protégé. L'expéditeur ne renonce pas aux droits et obligations
qui s'y rapportent.
Toute diffusion, utilisation ou copie de ce message ou des renseignements qu'il contient par
une personne autre que le (les) destinataire(s) désigné(s) est interdite.
Si vous recevez ce courriel par erreur, veuillez m'en aviser immédiatement, par retour de
courriel ou par un autre moyen.




--

Regards,

Stefan Hett
Mime
View raw message