subversion-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Ivan Zhakov <i...@visualsvn.com>
Subject Re: Subversion crashes on list with an empty format 3 repo
Date Sat, 06 Feb 2016 10:43:17 GMT
On 6 February 2016 at 01:49, Michael Osipov <michaelo@apache.org> wrote:
> Am 2016-02-05 um 22:10 schrieb Ivan Zhakov:
>>
>> On 5 February 2016 at 23:48, Michael Osipov <michaelo@apache.org> wrote:
>>>
>>> Am 2016-02-05 um 20:31 schrieb Ivan Zhakov:
>>>>
>>>>
>>>> On 5 February 2016 at 21:38, Michael Osipov <michaelo@apache.org> wrote:
>>>>>
>>>>>
>>>>> Hi folks,
>>>>>
>>>>> Subversion advised me to report this.
>>>>>
>>>>> The following command was performed:
>>>>> svn  --non-interactive list
>>>>>
>>>>>
>>>>> file:///D:/Entwicklung/Projekte/maven-wagon/wagon-providers/wagon-scm/src/test/resources/test-repo-svn
>>>>>
>>>>> The repo is available here [1], the crash files are here [2].
>>>>> The issue can always be reproduced, it does not require to run the
>>>>> tests
>>>>> with Maven on Maven Wagon.
>>>>>
>>>> I cannot reproduce:
>>>> [[[
>>>> svn  --non-interactive file:///D:/Ivan/temp/repos/test-repo-svn
>>>> dummy
>>>>
>>>> C:\Program Files\VisualSVN Server\bin>svn --version
>>>> svn, version 1.9.3 (r1718519)
>>>>      compiled Dec 15 2015, 11:23:08 on x86-microsoft-windows6.1.7601
>>>
>>>
>>>
>>> After further testing, I think I know why it does not fail for you. You
>>> have
>>> downloaded a tarball snapshot of the repo via Gitweb. I have retried with
>>> that one and Subversion does not crash. Aifter that, I ran SHA1 on all
>>> files, cloned via Git and from the tarball, they are different because
>>> Git
>>> transforms the db files and aligned the line ending.
>>>
>>> svnadmin verify crashes too.
>>>
>>> These might shred the repo:
>>> core.autocrlf=true
>>> core.eol=native
>>> core.safecrlf=true
>>>
>>> I have uploaded both repos to [1] as ZIP files.
>>>
>>> Can you kindly retry with a cloned repo or the ZIP files and report back?
>>>
>>> [1] http://home.apache.org/~michaelo/svn-crash-2016-02-05/
>>>
>> I downloaded archive and now I'm getting error about wrong FS type as
>> expected:
>> [[[
>> C:\Program Files\VisualSVN Server\bin> --non-interactive
>> file:///D:/Ivan/temp/repos/test-repo-svn
>> svn: E170013: Unable to connect to a repository at URL
>> 'file:///D:/Ivan/temp/repos/test-repo-svn'
>> svn: E180001: Unable to open repository
>> 'file:///D:/Ivan/temp/repos/test-repo-svn'
>> 'vn: E160033: Invalid name for FS type 'fsfs
>> ]]]
>
>
> Picking up my previous response, I just tried binaries from VisualSVN
> (probably the one you are using) and from SlikSVN. Both are working...is
> that now an issue I have to raise with CollabNet or some hidden bug in
> Subversion itself?
>
It could be some issue in CollabNet distribution, but we cannot
investigate without debug symbols of Collabnet Subversion binaries.


-- 
Ivan Zhakov

Mime
View raw message