subversion-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Daniel Shahaf <...@daniel.shahaf.name>
Subject Re: Problem setting up authz on svnserve
Date Sun, 07 Feb 2016 00:22:08 GMT
Rick Varney wrote on Fri, Feb 05, 2016 at 09:31:40 -0800:
> Errors I see in my svnserve.log that *may* be related are:
> 
> 28207 2016-02-03T18:31:50.113582Z xxx.xx.xx.xxx - - ERR - 0 210002 Network
> connection closed unexpectedly
> 
> 28540 2016-02-03T18:50:55.871361Z xxx.xx.xx.xxx - - ERR - 0 104 Can't read
> from connection: Connection reset by peer
> 
> But these only occurred rarely, and not each time I tried to access the
> repo and got the above client error.
> 

You can do 'svnserve --foreground -d --root=/path/to/repos
--listen-port=3691 --log-file=/dev/stdout' and test against that svnserve
instance to ensure the log messages are related to a particular client
action.  (You can run multiple instances in parallel.)

> At this point I'm stuck.  Am I doing anything obviously wrong?
> 
> Any suggestions on how I can debug this?

If *both* sides see a "Network connection closed unexpectedly" error at
the same time, I would suspect a firewall or proxy or a network
misconfiguration.  (That said, I don't see how enabling path-based authz
would affect the on-the-wire traffic, given that anon-access=none is set.)

Try 'svnauthz accessof' and check that your user is reported as "r" or "rw".

Try 'svn info svn://localhost' locally on the server: does it
fail in the same way as on the client?

Cheers,

Daniel

P.S. If you don't have /dev/stdout you can use --log-file=/dev/fd/1 or 
--log-file=$(tty).

Mime
View raw message