subversion-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Eric Antonio Maquiling <ericantoniomaquil...@gmail.com>
Subject svndumpfilter help
Date Wed, 03 Feb 2016 16:49:59 GMT

I have a new problem.  Not a problem with the software I think this is
sysadmin/user error.

I've read the docs and examples on how to use svnadmin dump and svndumpfilter.

I'm familiar with dumps and loads.  But I have a new task appointed to me.

I have a directory structure that looks like this:

svn://x.x.x.x/mainproject/branch/this_new_stuff

Developers want to take /this_new_stuff as a dump, and create a new repo so
it'll look like this:

svn://x.x.x.x/this_new_stuff

So far so good, I'll try svndumpfilter.

So I do:
svnadmin dump mainproject > mainproject.dump
svndumpfilter include this_new_stuff >  new_stuff_only.dmp
svnadmin create new_stuff
cd new_stuff
svnadmin load . < ../new_stuff_only.dmp
...
... lots of messages that it is loading
... it's going good, I'm getting stoked it is working
...
... whew, it's a lot, almost done

done.

Now I then go to my PC and do a tortoise browse svn://x.x.x.x/this_new_stuff

And it is EMPTY.

I look at the logs on tortoise and I can sell all the developer logs with the
check-ins

I've looked into new_stuff_only.dmp and see a lot of stuff

I've tried "dump-empty-revs and renumber-revs and preserve-revprops".  The
first 2 gives me that error inside the dump file that says something like
"empty this is just for padding or something like that'

Then I finally used "preserve-revprops" and I didn't get that error and the
logs show up with the developer check-ins.

Am I missing something?  Maybe another step?  All my googling just refers to
svnadmin dump and svndumpfilter.

I'm googling thins like "subversion dump folder into new repo" and I'm getting
svndumpfilter as the way to do it.

TIA!
-- 
eric

Mime
View raw message