subversion-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Hartleroad, James [IT]" <James.Hartler...@sprint.com>
Subject RE: svnlook changed doesn't include all of the files that are part of the commit
Date Mon, 23 Nov 2015 16:24:11 GMT
Version 1.8.10

$ svn log -r 5596 -v file:///data/ans/repos/r4BN
------------------------------------------------------------------------
r5596 | cmadmin | 2015-11-20 09:55:22 -0600 (Fri, 20 Nov 2015) | 15 lines
Changed paths:
   M /4BN/cmblds/1551-MID16.1.2.0
   A /4BN/cmblds/1551-MID16.1.2.0/4BN_Envs/dev/ReleaseChanges/MID16.1.2_Release_Changes.txt
(from /4BN/releases/1551-MID16.1.2.0/4BN_Envs/dev/ReleaseChanges/MID16.1.2_Release_Changes.txt:5591)
   M /4BN/cmblds/1551-MID16.1.2.0/4BN_FAST_source/DB_Scripts
   A /4BN/cmblds/1551-MID16.1.2.0/4BN_FAST_source/DB_Scripts/MID16.1.2 (from /4BN/releases/1551-MID16.1.2.0/4BN_FAST_source/DB_Scripts/MID16.1.2:5589)
   M /4BN/cmblds/1551-MID16.1.2.0/4BN_FAST_source/LDAP_Scripts
   A /4BN/cmblds/1551-MID16.1.2.0/4BN_FAST_source/LDAP_Scripts/MID16.1.2 (from /4BN/releases/1551-MID16.1.2.0/4BN_FAST_source/LDAP_Scripts/MID16.1.2:5590)

When I look at the svnbook.red-bean.com for 1.8, http://svnbook.red-bean.com/en/1.8/svn.ref.svnlook.c.changed.html,
I got the impression that new files added in a new directory would be shown.

If I run svnlook on the initial change, not the merge than the files are shown.
$ svnlook changed -r5589 /data/ans/repos/r4BN
A   4BN/releases/1551-MID16.1.2.0/4BN_FAST_source/DB_Scripts/MID16.1.2/
A   4BN/releases/1551-MID16.1.2.0/4BN_FAST_source/DB_Scripts/MID16.1.2/MID16.1.2_PJ019964_Epic363_ADD_New_Programs_DML_Changes.sql
A   4BN/releases/1551-MID16.1.2.0/4BN_FAST_source/DB_Scripts/MID16.1.2/MID16.1.2_PJ019964_Epic363_AUTO_ACTIVITY_WRKFLW_TASK_DML_Changes.sql

Just trying to get a better understanding on why svnlook shows the files when reviewing one
commit and not the other, when both commits "changed" what was in the repository, at least
to the point that the files are copied to the new location.



-----Original Message-----
From: Ivan Zhakov [mailto:ivan@visualsvn.com]
Sent: Monday, November 23, 2015 8:51 AM
To: Hartleroad, James [IT] <James.Hartleroad@sprint.com>
Cc: users@subversion.apache.org
Subject: Re: svnlook changed doesn't include all of the files that are part of the commit

On 23 November 2015 at 17:29, Hartleroad, James [IT] <James.Hartleroad@sprint.com> wrote:
> Why doesn’t svnlook changed show all of the files that are part of the
> commit?
>
> A developer created a new directory with two files in a branch and the
> branch was merged into another branch.  When running svnlook it shows
> the directory was added, but not the included files.  If I run a svn
> diff with the summarize option it does list the files, so shouldn’t
> svnlook include them too?
>
>
Thanks for problem report.

Could you please specify what version of Subversion do you use? Output of 'svn log -r 5596
-v file:///data/ans/repos/r4BN' (without log
message) will be also useful.


--
Ivan Zhakov

________________________________

This e-mail may contain Sprint proprietary information intended for the sole use of the recipient(s).
Any use by others is prohibited. If you are not the intended recipient, please contact the
sender and delete all copies of the message.
Mime
View raw message