subversion-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Bert Huijben <>
Subject Re: Subversion 1.8.13 on Cygwin: E170000 or E180001: Unable to connect to a repository at URL , Unable to open an ra_local session to URL
Date Fri, 26 Jun 2015 03:16:41 GMT
The cygwin version of Subversion is a unix compilation of subversion running on Windows, via
the cygwin libraries. As such it doesn't understand special Windoes paths.

If you would use a normal windows client (compiled for windows; not cygwin) it would understand
that it should transform file://myserver/share/path to \\myserver\share\path.

If you would like to use the cygwin version, you should probably map the network share and
then relocate your working copy.


Sent from Surface

From: MORGAN Marc
Sent: ‎Thursday‎, ‎June‎ ‎25‎, ‎2015 ‎3‎:‎47‎ ‎PM



I’ve been using subversion on my Windows 7 PC with Cygwin with a repository on a Linux server
accessed via file://.

I installed a brand new Cygwin version yesterday.

My local workspace lost its connection to the repository.

I can no longer access via svn the repository which I was previously using on the same PC.


% svn status -u

svn: E170000: Unable to connect to a repository at URL 'file://server/path/repository/trunk'

svn: E170000: Unable to open an ra_local session to URL

svn: E170000: Local URL 'file://server/path/repository/trunk'contains unsupported hostname


% svn ls file:////server/path/repository

svn: E180001: Unable to connect to a repository at URL 'file:///server/path/repository'

svn: E180001: Unable to open an ra_local session to URL

svn: E180001: Unable to open repository 'file:///server/path/repository'


% ls //server/path/repository

conf  dav  db  format  hooks  locks  README.txt


The new svn version is 1.8.13 (r1667537) on i686-pc-cygwin. The previous svn version I was
using is 1.6.17.


With file:// I get the E170000 error. With file:/// or file://// I get the E180001 error.


The repository directory is technically on another computer but is seen as local on my PC
(I guess it’s NFS or SAMBA) when accessed with the // prefix from the shell. 

I tried touch-ing a new file in the repository’s directory and that worked, with correct
owner, group and file permissions when checked from the Linux server.


If I copy the repository folder to my local /tmp, I can access it correctly via svn. But that’s
obviously not my goal.


If I access the repository via the URL  svn+ssh://somelinuxcomputer/nfspath/repository, that
works. But my experience with the SSH tunnel is that it tends to slow down access.


Has anyone experienced this problem before? Any suggestions?


Thanks in advance
View raw message