subversion-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Tim Schumacher <tim.schumac...@tourevo.com>
Subject Sporadic 500 Errors when checking out parts of the repository
Date Fri, 27 Feb 2015 11:23:58 GMT
Hi folks,

we have medium sized repository (~20k commits, 3GB of data, heavy
branching) and at night our buildserver checks out parts of our
application but sometimes it fails because he gets a 500 error from our
web server. The main problem is, that there is no entry in the error_log
of the apache and it happens only some of the time, not on all
occasions. The following entry is from the access_log:

192.168.120.25 - buildserver [27/Feb/2015:01:58:19 +0100] "OPTIONS
/svn/repo/trunk/400_Software/440_Server/448_routing HTTP/1.1" 500 801
"-" "SVN/1.7.5 SVNKit/1.7.5 (http://svnkit.com/) r9306_v20120621_1817"

Bit at 01:58:19 is no error_log entry.

This is the log of the client:

|27.02.2015 01:58:23:
Checking out http://vcs.taf.lan/svn/repo/trunk/400_Software/440_Server/448_routing revision:
HEAD depth:infinity ignoreExternals: false
ERROR: Failed to check out http://vcs.taf.lan/svn/repo/trunk/400_Software/440_Server/448_routing
org.tmatesoft.svn.core.SVNException: svn: E175002: OPTIONS of '/svn/repo/trunk/400_Software/440_Server/448_routing':
500 Internal Server Error (http://vcs.taf.lan)
svn: E175002: OPTIONS request failed on '/svn/repo/trunk/400_Software/440_Server/448_routing'|

This is the config:

<Location /svn/repo>
   DAV svn
   SVNPath /var/lib/svn/repo
   SVNPathAuthz off
   AuthType basic
   AuthName "Subversion Repository for Project repo"
   AuthBasicProvider ldap
   AuthLDAPURL
"ldap://sbs.taf.lan:389/OU=Users,OU=MyBusiness,DC=taf,DC=lan?sAMAccountName?sub?(objectClass=*)"
   AuthLDAPBindDN "ldap@taf.lan"
   AuthLDAPBindPassword ""
   require ldap-group  CN="repo VCS Users",OU="Security
Groups",OU=MyBusiness,DC=taf,DC=lan
</Location>

This server runs debian jessy with apache 2.4.10-9 and
libapache2-mod-svn 1.8.10-5.

So I have 2 questions:

1. Whats happening here?
2. How do I turn up the logging, so I get more Information about the 500
error?

Thanks for your time

Tim

ps When replying please set me on cc, since I am not subscribed to this
mailinglist.

-- 
TOUREVO Softwareentwicklung
c/o Intershop Tower
Leutragraben 1
07743 Jena

Fon:   +49 (3641) 50980-0
Fax:   +49 (3641) 50980-1
Mail:  tim.schumacher@tourevo.com


Mime
View raw message