subversion-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Trent Fisher <>
Subject Unable to parse reversed revision range
Date Tue, 10 Feb 2015 22:52:54 GMT
I am doing a dump/load of a repository, and ran into an odd (fatal) 
error on the load:

<<< Started new transaction, based on original revision 209
svnadmin: E200020: Unable to parse reversed revision range '29584-200'

I figured this would be easy enough to fix by adding 
--bypass-prop-validation to the load, but I got the same error.  I 
looked in the dump file, and sure enough, the rev numbers are backwards 
as stated.  However, I don't understand why load would fail.  I am just 
trying to do some repository migrations and I could care less whether 
those properties are correct or not, that's the users' problem (good 
attitude, eh? :)  Shouldn't --bypass-prop-validation cover this 
validation as well?

I thought about correcting the property, but since it is a versioned 
property, I'm not sure how it can be fixed (without doctoring the svn 
dump file).

I tried this with both SVN 1.6.11 and 1.8.9.  But both got the exact 
same error.

Is this a known problem (fixed since 1.8.9) or is there a workaround?


View raw message