subversion-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Tomasz Grobelny <tomasz.grobe...@makingwaves.pl>
Subject RE: E235000: assertion failed (SVN_IS_VALID_REVNUM(new_revision))
Date Wed, 21 Jan 2015 16:47:09 GMT
I am afraid that this may no longer be possible as I took a workaround and committed my changes
using TFS interface to codeplex repo.
I can roughly describe what the commit involved:
1. I copied one directory from openwaves\branches\0.1\src\OpenWaves.EPiServer to openwaves\OpenWaves.EPiServer\trunk\src\
OpenWaves.EPiServer6
2. I changed OpenWaves.EPiServer.csproj to OpenWaves.EPiServer6.csproj and OpenWaves.EPiServer.nuspec
to OpenWaves.EPiServer6.nuspec - both inside the above dir and both got modified
3. Modified the openwaves\OpenWaves.EPiServer\trunk\src\OpenWaves.EPiServer.sln file and added
app.config file in the above dir

Not sure if it helps tracking down the issue, but this is all I can remember to reproduce
the issue right now.

Tomek

-----Original Message-----
From: Philip Martin [mailto:philip.martin@wandisco.com] 
Sent: Wednesday, January 21, 2015 2:17 PM
To: Tomasz Grobelny
Cc: users@subversion.apache.org
Subject: Re: E235000: assertion failed (SVN_IS_VALID_REVNUM(new_revision))

Tomasz Grobelny <tomasz.grobelny@makingwaves.pl> writes:

>> That's failed in the code that runs on the client after the commit 
>> has succeeded.  It appears that the the client is acting as if the 
>> commit worked on the server but it has not got the newly committed 
>> revision.  If you look at the server/repository did the commit 
>> succeed?
>> 
> No it didn't - I cannot see the changes on the server (now connecting 
> to it as TFS repo).

The client sends an HTTP MERGE request to make a commit.  When the commit is successful the
server sends a 200 OK response that includes the new revision number and the client updates
the working copy.  In your case it seems the server sent a response that the client interpreted
as a successful commit but without the new revision number.
We would really like to see a network trace of the response.

The client may have broken the working copy when it tried to apply the missing revision number.
 You may have to check out a second working copy, compare to the first and manually transfer
the changes to the second working copy.

--
Philip Martin | Subversion Committer
WANdisco // *Non-Stop Data*

Mime
View raw message