subversion-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Grant Schoep <matobin...@gmail.com>
Subject Getting E160013 error on recursive svn prop list command
Date Wed, 07 Jan 2015 20:24:24 GMT
I'm running
SVN client (svn, version 1.8.8 (r1568071, from Collabnet RPM) (NOTE I've
tried a few different SVN versions on different machines for client side,
same results)
SVN server is running Subversion Edge 4.0.5

So I was trying to get an external tool(Crucible) to interact with our SVN
database. It chokes part way through. Digging through the logs it looks
like there might be something wrong with our SVN database.

I can reproduce this just with SVN on the command line. This problem only
appears down a certain path in the repo, on a specific revision.

So if I execute the following command

svn proplist -R -r 17672
https:/blah:12345/svn/stuff/web_services/ihas/trunk/@17672

It starts listing lots of Properties, but then bombs out with the following
issue

svn: E160013:
'/svn/stuff/!svn/rvr/17672/web_services/ihas/trunk/tmp/cache/assets/CDC/D90/752d90f7f232adf53395237b2d437a3a'
path not found

The exact part that is "not found" isn't always the same. But it is always
something in the "tmp" directory

If I refine the proplist a bit more and specify
svn proplist -R -r 17672
https:/blah:12345/svn/stuff/web_services/ihas/trunk/tmp/@17672

I get the same error, but it never seems to list anything.

So my feeling is something in this tmp revisioned directory is corrupt?

I ran an "svnadmin verify repopath" on this thing and it didn't report any
errors.

I am really at a loss of what to look at here. Any ideas of what to look at?

Mime
View raw message