subversion-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Cory Riddell <c...@codeware.com>
Subject Unable to hotcopy to a NAS shared directory: E720002
Date Tue, 20 Jan 2015 15:32:51 GMT
I'm trying to use hotcopy to create a backup of my repositories on a
network drive. When I run the hotcopy command, most of the repository
copies, then I get an error:

E:\>svnadmin hotcopy E:\MyRepo \\Diskstation\svn\MyRepo
svnadmin: E720002: Can't remove file
'\\diskstation\svn\MyRepo\db\rev-prop-atomics.shm': The system cannot
find the file specified.

I've tried mapping \\Diskstation\svn to a drive letter (Z:) and tried
forward slashes instead of back slashes, but nothing changes.

I've tried running the hotcopy command from an administrator command
prompt and get the same result.

My version of svnadmin is:
    svnadmin, version 1.8.11-SlikSvn-1.8.11-X64 (SlikSvn/1.8.11) X64
       compiled Dec  9 2014, 13:44:31 on x86_64-microsoft-windows6.2.9200

The server is running Windows 2012.

My NAS box is:
    Synology DiskStation
    DS412+
    SMB 2 is enabled

When I look for the rev-prop-atomics.shm file, it isn't there.

I know I could hotcopy the repository to a local directory, then use
rsync or robocopy to move it to the NAS, but it seems to me that I
shouldn't have to do that.

Any suggestions?

Thanks,
Cory








Mime
View raw message