subversion-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Alexey Neyman <>
Subject Problem with subversion-perl RPMs from WanDisco?
Date Thu, 11 Sep 2014 02:05:36 GMT
Hi all,

I tried to update subversion to 1.8.10 on a freshly installed CentOS 6.5 and 
noticed that an attempt to use Perl bindings has failed due to an undefined 
symbol in the libsvn_swig_perl library: svn_swig_pl_get_current_pool

$ readelf -Ws /tmp/usr/lib64/ | grep svn_swig_pl_get_
    79: 0000000000000000     0 NOTYPE  GLOBAL DEFAULT  UND 

This symbol is defined in the library packaged into 1.9.0-alpha2 RPMs, but not 
in any 1.8.x/1.7.x RPMs.

I have also tried on another machin - it originally had CentOS 6.0 installed + 
partially upgraded. There, the Subversion Perl bindings from WanDisco's RPM 
just coredump in Repos::Open - I am not sure if it is the same issue or not. 
It works with the original CentOS version of subversion-perl (1.6.x).


View raw message