subversion-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Mohsin Abbas <mohsinchan...@gmail.com>
Subject Re: Subversion 1.8.9 repository access issue [Urgent]
Date Fri, 04 Jul 2014 23:57:48 GMT
Hello sir,

Hope you are doing well . I have installed SVN V1.8.9 with Apache 2.2.24
all repositories are working fine except one which gives following error
when I access from browser. Can you please help me why this specific
repository is giving error while others are working fine .

Note : Previous SVN version was 1.4.2 I have installed latest SVN V1.8.9
and r synced SVN V1.4.2 repositories.

*Apache error log portion :*

[Fri Jul 04 15:07:43 2014] [error] [client 192.168.x.x] (20014)Internal
error: Failed to load module for FS type 'bdb'
[Fri Jul 04 15:07:43 2014] [error] [client 192.168.x.x] Could not fetch
resource information.  [500, #0]
[Fri Jul 04 15:07:43 2014] [error] [client 192.168.x.x] Could not open the
requested SVN filesystem  [500, #160033]
[Fri Jul 04 15:07:43 2014] [error] [client 192.168.x.x] Could not open the
requested SVN filesystem  [500, #160033]


Regards
Mohsin


On Wed, May 21, 2014 at 4:10 PM, Stefan Sperling <stsp@elego.de> wrote:

> On Wed, May 21, 2014 at 07:28:34PM +0500, Mohsin Abbas wrote:
> > I want to add one point all repositories are accessible when I access
> > through browser but encountered above reported issue when access through
> > tortoise SVN client why this happen I mean If this is bug in Apache HTTPD
> > then It should not work in browser too .. What to you say about this ?
>
> Normal browsers do not interact with the repository in the way SVN
> clients do. SVN clients use an expanded set of HTTP requests which
> most web browsers don't use (I think browsers only use GET requests in
> this context). Because of this the problem only shows with SVN clients.
>
> SVN clients use Webdav/DeltaV: http://en.wikipedia.org/wiki/Webdav
>

Mime
View raw message