subversion-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Mark Phippard <markp...@gmail.com>
Subject Re: Extend E155021 message to include supported format version
Date Fri, 04 Jul 2014 18:03:25 GMT
On Fri, Jul 4, 2014 at 11:16 AM, Notes Jonny <jongmob@gmail.com> wrote:

> Hi Mark
>
> You are right that I did have 1.8.x installed. Which I downgraded to
> this version:
>
> TortoiseSVN 1.7.7, Build 22907 - 32 Bit , 2012/05/15 12:16:05
> Subversion 1.7.5,
> apr 1.4.6
> apr-utils 1.3.12
> neon 0.29.6
> OpenSSL 1.0.1c 10 May 2012
> zlib 1.2.7
>
> NB. I don't know why tortoise is called 1.7.7 and subversion uses
> 1.7.5 - would be simpler if they matched.
>

TortoiseSVN is its own product with own features and bugs to fix.  So it
needs its own release schedule and numbering.  The significant part of any
Subversion release is the major.minor part.  So 1.7.  All 1.7.x releases
are compatible both at binary/API level but also formats such as working
copy.  So your TortoiseSVN version is 1.7.7 and it is using version 1.7.5
of the Subversion libraries.

Given all the security fixes in Subversion and OpenSSL since the versions
you have I would recommend updating TortoiseSVN to the latest 1.7.x version
 I recall it was 1.7.14.  This would still be fully compatible with your
Jenkins and Cygwin versions.

-- 
Thanks

Mark Phippard
http://markphip.blogspot.com/

Mime
View raw message