subversion-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From OBones <obo...@free.fr>
Subject Re: Ran svn revert but files are still modified
Date Fri, 18 Jul 2014 15:14:00 GMT
Andreas Stieger wrote:
> Hi,
>
>> On 18 Jul 2014, at 13:51, OBones <obones@free.fr> wrote:
>>
>> I have a working copy here where a file is in status "modified" which won't go away.
>> This file is a binary database dump (.bak) and I don't understand why this happens
on that file while there are other files with that extension in the same folder that do not
behave the same.
>> I tried running "svn revert" and "svn cleanup" but this did not make the file go
back to unmodified.
> Did you run revert recursively with "-R", or did you run it on the item specifically?
Without that, do not expect the file to be reverted.
I ran "svn revert ." but you are correct, this does nothing to my file.
But I ran "svn revert -R ." and "svn revert *" and the same behavior 
happens.
I tells me "Item reverted" then immediately comes back as modified in 
svn status. I even went as far as running them in sequence like that:

svn rever * & svn status

I get this output:

'TheFile.bak' reset
M       TheFile.bak

>> When using WinMerge to see the diffs, it tells me the file is identical to its base.
> Note that your third-party diff tool may be configured to ignore certain changes like
line ending formats etc
>
> Check your diff tool invocation settings, and check the authoritative "svn diff" on the
specific item.
svn diff is unable to show the difference, it shows this:

Index: TheFile.bak
===================================================================
Unable to display : file considered as binary.
svn:mime-type = application/octet-stream

As to WinMerge, it is configured to take all differences it knows about 
into account and still tells me that there are no differences.

Mime
View raw message