subversion-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From OBones <obo...@free.fr>
Subject Re: Ran svn revert but files are still modified
Date Fri, 18 Jul 2014 15:11:31 GMT
Stefan Sperling wrote:
> On Fri, Jul 18, 2014 at 01:51:07PM +0200, OBones wrote:
>> Hello,
>>
>> I have a working copy here where a file is in status "modified" which 
>> won't
>> go away.
>> This file is a binary database dump (.bak) and I don't understand why 
>> this
>> happens on that file while there are other files with that extension 
>> in the
>> same folder that do not behave the same.
>> I tried running "svn revert" and "svn cleanup" but this did not make the
>> file go back to unmodified.
>> When using WinMerge to see the diffs, it tells me the file is 
>> identical to
>> its base.
> What files does WinMerge compare exactly? Perhaps it's not comparing
> the right set of files?
When ran from TortoiseSVN, this is the command line it gets:

"C:\Program Files (x86)\WinMerge\WinMergeU.exe" -e -x -ub -dl 
"TheFile.bak : Working Base, Revision 35975" -dr "TheFile.bak : Working 
Copy" 
"C:\Users\obones\AppData\Local\Temp\TheFile.bak-revBASE.svn002.tmp.bak" 
"D:\Sources\Some\Path\TheFile.bak"

If I run svn diff on the command line, here is what I get:

Index: TheFile.bak
===================================================================
Unable to display : file considered as binary.
svn:mime-type = application/octet-stream

I used ProcessMonitor to see who is accessing that file and besides 
svn.exe, nothing is accessing it...

Mime
View raw message