subversion-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Croft, Joe" <>
Subject New subversion bug?
Date Mon, 16 Jun 2014 15:40:25 GMT
Hi Yall,

I ran into the problem that when I do an svn copy command three times, it behaves differently
each time. The command line is:

svn cp

The first time I run this I end up with what I expect, a directory with the url of

which contains the files and folders which are under 'trunk' of the original url.

The second time I run this I get an unexpected directory with the folder

which also contain all of the folders and files which are under the 'trunk' of the original

On the third and subsequent executions of the same command, I get the error I expected on
the second invocation except for the url that it complains about already existing. The error

                Svn: E160020: Path 'trunk' already exists.

I really  the error "Svn: E160020: Path 'tag_a' already exists" on the second invocation of
the command.

I am running with svn server 1.6 on linux. The client can be windows or linux 1.6 or 1.7.
Adding a trailing slace ("/") to the urls does not help, nor does providing a revision option
to the command.

   Thank you,


This e-mail message (including any attachments) contains confidential, non-public information.
It also may be protected by the attorney/client or other applicable privileges. It is intended
to be communicated only to the designated recipient(s). Unauthorized use, reproduction, dissemination,
or communication of this message or any information contained in this message is strictly
prohibited and may be unlawful. If you are not an intended recipient of this message, please
notify the sender promptly by e-mail or telephone at the sender's location indicated above
or contact Shure Incorporated at or 800-25-SHURE (800-257-4873).

View raw message