subversion-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Daniel Shahaf <...@daniel.shahaf.name>
Subject Re: AuthUserFile not specified in the configuration
Date Fri, 04 Apr 2014 09:24:41 GMT
Justin Mrkva wrote on Thu, Apr 03, 2014 at 00:53:41 -0400:
> [error] [client ::1] AuthUserFile not specified in the configuration
> 
> Apache runs as _www:_www, and the directory containing the repository as well as the
repos themselves are all _www:_www 755. The htdigest file is _www:_www 644. The realm for
the user matches the httpd.conf AuthName. The password is correct. Both SVNParentPath and
AuthUserFile are the correct paths.
> 
> Here are relevant lines from httpd.conf:
> 
> LoadModule auth_digest_module libexec/apache2/mod_auth_digest.so
> LoadModule dav_svn_module /usr/local/libexec/mod_dav_svn.so
> LoadModule authz_svn_module /usr/local/libexec/mod_authz_svn.so
> 
> <Location /svn>
>     DAV svn
>     SVNParentPath /Library/Subversion/Repositories
>     SVNListParentPath on
>  
>     AuthName "Subversion"
>     AuthType Digest
>     AuthDigestProvider file
>     AuthUserFile /private/etc/svnauth.htdigest

Does 'sudo -u _www wc -l -- /private/etc/svnauth.htdigest' work?

(I'm suspecting /private might be unreadable by _www.)

Another possibility is that httpd treats GET and OPTIONS requests
differently, i.e., that some other part of the config kicks in for the
latter but not for the former.

>  
>     Require valid-user
>     Allow from all
> </Location>

Mime
View raw message