subversion-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Torsten Budesheim <torst...@gmail.com>
Subject Not enough infer to resolve 'loaded an incompatible library'
Date Thu, 13 Mar 2014 13:35:01 GMT
Hi,

I’m trying to resolve an issue I’m having with subversion on my Mac OS 10.9.2. I installed
subversion via Homebrew and it had previously worked. I can’t say for sure anymore what
exactly happened, but recently this is what happened (not necessarily in exactly that order):

 1) Installed the upgrade to Mac OS 10.9.2
 2) Upgraded to Xcode 5.1 + Command Line Tools
 3) Upgraded subversion to 1.8.8

I since tried to remove subversion via ‘brew remove subversion’ and reinstalled it as
follows (the error still persists though):

~: brew install --with-python --build-from-source subversion
==> Downloading http://www.apache.org/dyn/closer.cgi?path=subversion/subversion-1.8.8.tar.bz2
Already downloaded: /Library/Caches/Homebrew/subversion-1.8.8.tar.bz2
==> Patching
patching file subversion/bindings/swig/perl/native/Makefile.PL.in
Hunk #1 succeeded at 76 (offset 7 lines).
patching file configure.ac
==> Downloading http://serf.googlecode.com/svn/src_releases/serf-1.3.4.tar.bz2
Already downloaded: /Library/Caches/Homebrew/subversion--serf-1.3.4.tar.bz2
scons: Reading SConscript files ...
scons: done reading SConscript files.
scons: Building targets ...

Then it compiles without any errors. But when I try to run svn from the command line, I get
an error:

 ~: svn
svn: E200019: ra_serf was compiled for serf 1.3.4 but loaded an incompatible 1.1.1 library


How can I identify the incompatible version 1.1.1 library that is being loaded and/or how
do I fix this?


Thanks,
Torsten
Mime
View raw message