On Mon, Sep 9, 2013 at 9:20 AM, James French <James.French@naturalmotion.com> wrote:


-----Original Message-----
From: Johan Corveleyn [mailto:jcorvel@gmail.com]
Sent: 09 September 2013 14:13
To: James French
Cc: users@subversion.apache.org
Subject: Re: svn: E120104: ra_serf: An error occurred during decompression

On Mon, Sep 9, 2013 at 3:02 PM, James French <James.French@naturalmotion.com> wrote:
> I tried it again with the 1.8.3 command line and the merge went through...

Okay, I'm happy for you that it worked :-). However, I'm not convinced the error is gone. In my case it would also only fail intermittently.
I couldn't reproduce it all the time (it happened perhaps 1 in 4 or 5 attempts).

If you would run into the error again, please let us know ...

(in my case, we were able to reduce the reproduction recipe, by only doing an 'svn export --depth=immediates http://svn.apache.org/repos/asf/subversion/tags/1.8.3/' -> within a couple of attempts of that export I would run into the issue (I can reproduce it with both serf 1.2.1 and 1.3.1). Maybe you can also try exactly this export a couple of times?)

Tried it with 1.8.3 wandisco about 20 times and it never failed. Tried it with 1.8.1 collabnet and it failed first time.
Is the version of serf used dependent on the distro then, and not a core svn thing?

Serf 1.3.1 was not released until after SVN 1.8.1 came out.  So pretty much anyone's SVN 1.8.1 binaries would be using Serf 1.3.0 or earlier.

To answer the general question, while most SVN distros do happen to be using the same versions of most of these dependencies they are nonetheless absolutely dependent on the distro and what version they happen to have used to build the distribution.

--
Thanks

Mark Phippard
http://markphip.blogspot.com/