subversion-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Felipe Alvarez <>
Subject Re: svn 1.8 causing locks to be broken on update
Date Wed, 14 Aug 2013 10:05:22 GMT
> I have the same issue.
> It happens when I run 1.8.1 windows client with 1.6.9 https
> repository sever. I haven't tried so many combinations ATM,
> but here are some observations:
> 1.8.1 client run with 1.6.9 https:// repo server gives this issue.
> 1.8.1 client run with 1.6.9 generated file:/// repositories are OK.
> 1.8.1 client run with 1.7.6 generated file:/// repositories are OK.
> 1.7.6 client run with 1.6.9 https:// repo server is OK.
> Whether the WC is freshly checked out by 1.8.1 client, or upgraded
> from 1.7.6 checked out WC did not change the results.
> How's the case for the original poster? Do we see something
> in common?
> # I'm reading this ML through the archives.
> --
> Hiroharu

Hi Hiroharu

You are indeed correct. We have done a very similar experiment here, too.
We tried all of the above scenarios you gave. But our older client was
1.6.15, and we did not use https, we used http (apache 2.2)

With the help of my colleague we have done some testing with svn 1.8.1
(windows 7 and Ubuntu) client and svn 1.6.15 (redhat 5.5) client.

Using the file:/// method in all cases works fine (locks NOT broken). All
other methods also work fine, including http. Of the tests we made, the one
which breaks the locks is: client 1.8.1; repository made with svn 1.6.15;
protocol HTTP (apache 2.2).

One method that we have not yet tried is: client 1.8.1; repo with svn
client 1.8.1; protocol HTTP

How do I enabled debugging in .subversion/config or .subversion/servers? It
used to be something like "neon-debug" but that's no longer available since
1.8.1 (or 1.8)

-- felipe

View raw message