subversion-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From John Maher <Jo...@rotair.com>
Subject RE: Switching
Date Thu, 22 Aug 2013 18:39:13 GMT
You digress.  Not a single one of the compiled libraries lives within the versioned directories.
 Please read the question before replying incorrectly.  It has nothing to do with code.  It
has nothing to do with the build.  Please ask for clarification if you do not understand.
 You gave a good suggestion with the force option.  Then you wandered off to completely irrelevant
ramblings.  Should quit while you're ahead.

-----Original Message-----
From: Edwin Castro [mailto:0ptikGhost@gmx.us] 
Sent: Thursday, August 22, 2013 2:30 PM
To: users@subversion.apache.org
Subject: Re: Switching

On 8/22/13 10:54 AM, John Maher wrote:
> This happens even if you do not do a build.  There is a class library in one branch but
not the other mixed with unversioned files that I can do nothing about.

Statements like this make me believe that build system is broken. I would expect the svn switch
like problems on nearly any SCM you use that has the ability to switch a single working copy
(or workspace, client,
what-have-you) between branches. My knee jerk reaction in situations like this is to fix the
build system.

Are you sure there is nothing you can do? Perhaps you can suggests a simple fix like moving
the versioned class library to a location that is always versioned. For example, instead of
referencing a class library that lives in a bin/ directory it is better to keep the class
library in a lib/ directory instead. Build output goes in the unversioned bin/ directory and
versioned resources go in the lib/ directory.

--
Edwin G. Castro




Mime
View raw message