subversion-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Philip Martin <philip.mar...@wandisco.com>
Subject Re: Subversion compilation
Date Wed, 07 Aug 2013 10:19:23 GMT
Daniel Shahaf <danielsh@elego.de> writes:

>> bash-3.2$ /home/userb/svn/bin/svn co http://svnserver/svn/repositoryA/ /tmp/repoA/
>> /home/userb/svn/bin/svn: symbol lookup error: /home/userb/svn/lib/libsvn_ra_neon-1.so.0:
undefined symbol: ne_accept_207
>> 
>> Version was 1.7.9, compiled with the following options (it gnored --without-apache
though).
>> ./configure  --without-berkeley-db --without-apache --without-apxs --without-swig
 --with-ssl --with-serf=/home/userb/local/serf   --prefix=/home/userb/svn
>> 
>> I've added path to svn lib in LD
>> bash-3.2$ ldd /home/userb/svn/bin/svn | grep neon
>>         libsvn_ra_neon-1.so.0 => /home/userb/svn/lib/libsvn_ra_neon-1.so.0 (0x00002b3846cff000)
>> 
>
> It appears libneon itself is missing; compare:
>
> % ldd /usr/bin/svn | grep neon
>         libsvn_ra_neon-1.so.1 => /usr/lib/libsvn_ra_neon-1.so.1 (0x00007f988087c000)
>         libneon-gnutls.so.27 => /usr/lib/libneon-gnutls.so.27 (0x00007f987e7d7000)

Perhaps neon is static?  I seem to recall that building neon defaults to
static only unless there is an explict --enable-shared.

>> serf was 0.7.2 and apr was 1.4.5
>> 
>
> serf-0.7 is old, but anyway, things should just work if you use
>
>   --config-option=servers:global:http-library=serf
>
> to your command line.

That probably won't help since the linker is failing to load the linked
library at program startup.  It might work if Subversion was configured
with --enable-runtime-module-search.  It would be better to fix the
libneon problem.

-- 
Philip Martin | Subversion Committer
WANdisco | Non-Stop Data

Mime
View raw message