subversion-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Philip Martin <philip.mar...@wandisco.com>
Subject Re: svn 1.8 causing locks to be broken on update
Date Wed, 14 Aug 2013 22:46:03 GMT
Felipe Alvarez <felipe.alvarez@gmail.com> writes:

>>
>>
>> I have the same issue.
>>
>> It happens when I run 1.8.1 windows client with 1.6.9 https
>> repository sever. I haven't tried so many combinations ATM,
>> but here are some observations:
>>
>
> Hi Hiroharu
>
> You are indeed correct. We have done a very similar experiment here, too.
> We tried all of the above scenarios you gave. But our older client was
> 1.6.15, and we did not use https, we used http (apache 2.2)
>
> With the help of my colleague we have done some testing with svn 1.8.1
> (windows 7 and Ubuntu) client and svn 1.6.15 (redhat 5.5) client.

Can you provide a complete recipe?

I'm using a 1.8.x client and a 1.6.x server and I can't reproduce it. I
tried this

svnadmin create repo --compatible-version 1.6
svn co http://localhost:8888/obj/repo wc
svn mkdir --parents wc/A/B/C
touch wc/A/B/C/f
svn add wc/A/B/C/f
svn ci -mm wc
svn up wc
svn lock wc/A/B/C/f
cd wc/A
svn up
cd ..
svn up
cd ..
svn st wc

and the final status shows wc/A/B/C/f still locked.

-- 
Philip Martin | Subversion Committer
WANdisco // *Non-Stop Data*

Mime
View raw message