subversion-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Bert Huijben" <b...@qqmail.nl>
Subject RE: svn 1.8.1 fails on underscore in the tunnel protocol
Date Fri, 16 Aug 2013 23:17:59 GMT


> -----Original Message-----
> From: Branko ─îibej [mailto:brane@wandisco.com]
> Sent: vrijdag 16 augustus 2013 23:29
> To: users@subversion.apache.org
> Subject: Re: svn 1.8.1 fails on underscore in the tunnel protocol
> 
> On 16.08.2013 23:10, Eric Hall wrote:
> > Hello-
> > 	We have a custom tunnel protocol withrepository URLs of the form:
> >
> > 		svn+foo_bar://
> >
> > 	After upgrading from svn 1.7.x to 1.8.1, these URLs are considered
> > invalid, giving an error of:
> >
> > 		svn: E170000: Illegal repository URL
> >
> > 	This occurs on an 'svn up' or an 'svn checkout'.
> >
> > 	Changing the tunnel protocol name to 'foobar' (i.e. drop the
> underscore)
> > appears to work properly, both 'svn up' and 'svn checkout' work fine.
> >
> > 	Is this a bug, or should tunnel protocols not have underscores in
> them?
> 
> See RFC 3986, section 3.1:
> 
> http://www.ietf.org/rfc/rfc3986.txt
> 
> Underscores are not allowed in the URL scheme. It would appear that
> allowing them was a bug in previous versions of Subversion.

The related change was not in Subversion itself, but in apr-util 1.5.2.
[[
  *) apr_uri_parse(): Do not accept invalid characters in the scheme.
     Per RFC 3986 3.3, enforce that the first segment of a relative path does
     not contain a colon. PR 52479.
]]

	Bert


Mime
View raw message