subversion-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Gunnar Dalsnes <>
Subject Re: svn 1.8.0 problem "both sides of the move must be committed together"
Date Tue, 02 Jul 2013 14:05:36 GMT
On 02.07.2013 15:33, Stefan Sperling wrote:
> On Tue, Jul 02, 2013 at 03:11:27PM +0200, Gunnar Dalsnes wrote:
>> Hi,
>> When I try to commit I get:
>> svn: E200009: Commit failed (details follow):
>> svn: E200009: Cannot commit 'E:\svn\fishtalk trunk\src\VPA
>> Framework\VPAEntities
>> \Wrasse\BLEWrasseContainer.cs' because it was moved to
>> 'E:\svn\fishtalk trunk\sr
>> c\Plugins\Registration\BLEntities\Wrasse\BLEWrasseContainer.cs'
>> which is not par
>> t of the commit; both sides of the move must be committed together
>> This is strange, because I correctly moved the files with TSVN 1.8.0
>> using "SVN Move versioned item(s) here". Tried commiting from both
>> TSVN and from command line with svn.exe and same error.
>> When I check with svn status I get this:
>> <lots of other unrelated adds, mods and deletes>
>> A       src\Plugins\Registration\IBLPWrasse\Entities
>> A  +    src\Plugins\Registration\IBLPWrasse\Entities\BLEWrasseContainer.cs
>> D       src\VPA Framework\VPAEntities\Wrasse\BLEWrasseContainer.cs
>>          > moved to
>> src\Plugins\Registration\BLEntities\Wrasse\BLEWrasseContainer.cs
>> This seems to confirms that I moved the file correctly.
> Strange. The status output only shows one side of the move.
> Where does it show a 'moved from'? Did you accidentally omit
> the '> moved from' line from the output you pasted?

There is no > moved from line showing for BLEWrasseContainer.cs in svn 

>> Update: I finally managed to commit by only selecting the deleted
>> source file, added destination file and added destination folder
>> (ignoring all other changed):
>> Command: Commit
>> Adding: E:\svn\Copy of fishtalk
>> trunk\src\Plugins\Registration\IBLPWrasse\Entities
>> Adding: E:\svn\Copy of fishtalk
>> trunk\src\Plugins\Registration\IBLPWrasse\Entities\BLEWrasse.cs
>> Deleting: E:\svn\Copy of fishtalk trunk\src\VPA
>> Framework\VPAEntities\Wrasse\BLEWrasse.cs
>> Sending content: E:\svn\Copy of fishtalk
>> trunk\src\Plugins\Registration\IBLPWrasse\Entities\BLEWrasse.cs
>> Completed: At revision: 24489
>> Still, very annoying. This can't be right.
> It looks like you moved a file BLEWrasse.cs into a locally added folder
> called Entities. To commit the move destination you also need to commit
> the new folder that contains the move destination. I don't really
> understand what you think is wrong that. Am I missing something?

Sorry, I was confused, this is a different and unrelated file. This file 
actually has a > moved from entry, that's why it worked.


View raw message