subversion-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From C M <cmanalys...@gmail.com>
Subject Re: Ancestrally Related Error Message
Date Mon, 17 Jun 2013 16:39:20 GMT
I think my earlier mistake might have been that I was using the
--reintegrate option.
Without it, I make some progress, but still not quite what I am expecting.

Again, given that trunk is empty, why the "C" (tree conflicts)? I would
expect all of then to be "A" (additions), no?

The DEV_WC currently only shows the two dirs which SVN correctly recognized
as additions.

c:\Temp\DEV_WC>svn merge --dry-run --ignore-ancestry
https://path_to_branch/SCR_BR/

--- Merging r1191 through r1245 into '.':
   C ini
   C txt
   C graphics
   C MMI
   C backups
   C sysctrl
A    sysconfig
A    sysconfig\src
A    sysconfig\src\sysconfig
A    sysconfig\src\sysconfig.c
A    sysconfig\src\sysconfig_init.c
A    sysconfig\src\log
A    sysconfig\src\makefile
A    sysconfig\inc

   C cpu
A    mtl
A    mtl\lib
A    mtl\lib\mtl.lib
A    mtl\src
A    mtl\src\mtl_meter.c
A    mtl\src\mtl
A    mtl\src\makefile
A    mtl\src\mtl.c
A    mtl\inc
A    mtl\inc\mtl_meter.h
   C util_panel
 U   .
Summary of conflicts:
  Tree conflicts: 8


On Mon, Jun 17, 2013 at 10:38 AM, C. Michael Pilato <cmpilato@collab.net>wrote:

> On 06/17/2013 11:19 AM, C M wrote:
> > Hello,
> >
> > Code for a new development effort was imported into a developer’s branch.
> >
> > Now we want merge his changes to trunk (which is currently empty).
> >
> > I tried the merge from both the command line and the Tortoise GUI and
> keep
> > running into the “…must be ancestrally related…” message.I also tried the
> > "ignore ancestry" option via the GUI.
> >
> > One, I don't understand why SVN thinks there is even an ancestral
> > relationship betweeen the two locations?
>
> Subversion doesn't think there is.  Rather, it knows there isn't.  Hence
> the
> message.  The error was introduced to prevent a common mistake folks make
> when they misalign their merge sources and targets:
>
>    $ svn merge ^/trunk branches
>    ^C^C^Cdangit i meant to type "branches/my-branch"^C^Caaaaagh!
>
> > Two, how can I do to get around this error message?
>
> Well... the --ignore-ancestry option was *supposed* to make that happen for
> you.  Perhaps there's a bug?
>
> You may need to give a more complete transcript of what you're trying,
> including command-line examples and such.
>
> --
> C. Michael Pilato <cmpilato@collab.net>
> CollabNet   <>   www.collab.net   <>   Enterprise Cloud Development
>
>

Mime
View raw message